JTL-Shop3, IonCube und PHP5.5

Wichtige Hinweise zur Kompatibilität von JTL-Shop3 mit PHP 5.5 und ein Ausblick auf die nächste Shopversion 3.19.
Von D. Hannappel vor fast 4 Jahren hinzugefügt

JTL-Shop3 wird größtenteils mit offenem PHP-Quellcode ausgeliefert, jedoch sind bestimmte Teile wie der Admin-Bereich, oder die Schnittstelle zu JTL-Wawi verschlüsselt.
Diese Verschlüsselung ist für JTL-Shop3 mit dem IonCube-Encoder in Version 6.5 realisiert.
Diese Ioncube-Encoder-Version ist kompatibel zu den PHP-Versionen 5.2 bis einschließlich PHP5.4 sowie älteren IonCube-Loadern (auch solche, die zum Release von Shop3 im Oktober 2010 aktuell waren).

Eine Kompatibilität zu PHP5.5 wird erst mit JTL-Shop 3.19 mit einem alternativen Downloadpaket sichergestellt. Diesen Download erhalten Sie nach Release von JTL-Shop3.19 zunächst auf Anfrage via Ticket.
Mit dem Wechsel auf den aktuellen IonCube-Encoder müssen gleichzeitig die Systemvoraussetzungen für JTL-Shop3.19 angehoben werden:
  • PHP ab Version 5.3 (zuvor 5.2) bis einschließlich 5.5.
  • IonCube-Loader ab einschließlich Version 4.5.

Zusammenfassung

  • JTL-Shop3 ist standardmäßig aufgrund der IonCube-Verschlüsselung lauffähig auf Systemen mit PHP5.2 bis PHP5.4.
  • Kompatibilität zu PHP5.5 kann nur mit einem Update auf aktuelle IonCube-Encoder und -Loader-Versionen sichergestellt werden.
  • JTL-Shop3.19 wird in einem alternativen Download-Paket mit einer neuen IonCube-Encoder-Version verschlüsselt werden (nur die Dateien, die in bisherigen Versionen auch verschlüsselt waren). Das alternative Download-Paket für PHP5.3-PHP5.5 kann via Ticket-Anfrage nach Release von JTL-Shop3.19 angefordert werden. Bitte stellen Sie in diesem Fall sicher, dass mindestens PHP5.3 und ein aktueller IonCube-Loader >= 4.5 zur Verfügung stehen.

Kommentare